Sign up
Store
Badlion Client Setup
HELP ME
Badlion Client needs at least Windows 7 Servise Pack 1 to operate properly. You need to to download Servise Pack 1
 1
PM Link
This is not the right spot to put this.
https://www.badlion.net/forum/category/4
 0
PM Link