Sign up
Store
Subscribe
Badlion Client and MacOs "Big Sur" update.
I recently have updated my MacBook to MacOs "Big Sur", and tried to join BLC Minecraft in the version 1.8.9, but It gave me a black screen, I attempted that join again but this time it gave me a white screen. I don't know if this has to do with the MacOs "Big Sur" update or if it has to do with some other reason.
 3
PM Link
I'm having the exact same issue since I downloaded the most recent Mac update, "Big Sur". I try to join 1.8.9 and a white screen completely fills up the whole screen. There's no way to get rid of it without force quitting (Option, command, esc).
Will there be any fixes to this because I am staff on a Minecraft server and obviously need to be able to get in-game.
 6
PM Link
The exact same thing happens to me! I would recommend you to go to their discord server and submit a bug report there. You also may want to submit a bug report via badlion, which you can do by scrolling to the bottom of the launcher. Hope this helped, if they do not fix this their macOS users will start dropping like flies. Cheers!
 0
PM Link
An image of what occurs is accessible by clicking on this snazzy blue text.
 0
PM Link
I've also been experiencing this bug on macOS Big Sur. I've managed to get it working by launching Minecraft a few times until it worked, hopefully this will also work for the rest of you guys and girls having this issue!
 1
PM Link
Nothing works for me, I really need to make it work, please help URGENT, im a youtuber and i need this
 0
PM Link
disabling optifine the game works
 0
PM Link
For me everything works as it should.
 0
PM Link
@BlackGummy93 But OptiFine is good
 0
PM Link
Hello fellow macOS users.

I am receiving my new Macbook Air next week and will be testing out BLC on Big Sur and the new M1 chips.

We are planning to try and eventually release a compliant ARM build also, but this might take a bit of time.

Unfortunately it sounds like you guys are experiencing some software compatibility issues or graphics driver bugs…I would actually report them to Apple directly as their Rosetta 2 software should be handling all of this. It is a brand new operating system release though with a huge amount of changes and bugs are to be expected.

Thanks.
 8
PM Link
Yes! This had been a problem I had been dreading about for the past few days. Just turn of optifine and it'll work just fine. And if you really want the zoom, get the zoom mod which when you use your mouse scroll it is better than optifine tbh.
 0
PM Link
Thank you so much BlackGummy03! It seems to be an optifine-badlion-big sur issue. Personally I use shaders but I can live without them. Thank you Mr. Gberry for your input.
 0
PM Link
shaders on macos? Madlad
 0
PM Link
Hi!
So I just found a temporary workaround:
Just change Badlion Path to something other like eg. /users/somebody/minecraft2
 0
PM Link
I am going to pin this thread for now since I am sure a lot of users will be experiencing random problems with Big Sur and this is a good place for the community to talk and help each other while we get any compatibility issues sorted.
 7
PM Link
Man fix this quicker Im bored :( I want to play Badlion ;)
 2
PM Link
@BlackGummy93 I disabled optifine and it is still a white screen :/
 2
PM Link
Just as a quick status update from my own side, i got my new Macbook Air with the M1 chip…Badlion Client does not work on it with or without emulation currently…

Most of the tools/software I am using is still upgrading to M1 support…so i guess maybe around Christmas we will have compatibility with the M1 architecture…fingers crossed. Keeping a very close eye on a bunch of things for it…but Java doesn't even have native Apple Silicon support yet…so the performance will be really bad with the Rosetta 2 emulation ='(

I'll ask one of my devs if he can look into upgrading his laptop to Big Sur so we can look into the other problems in this thread in the meanwhile, but they might be macOS graphics driver problems that will just be fixed in time.
 2
PM Link
Last time I launched Badlion (with big sur) and this happend I took a screenshot when it happened

The picture is here (sorry for the low graphics)
 0
PM Link
I searched for the Problem on Github and there they said that it is an Optifine Problem (Compatibility).
So I guess We Should Wait Until OptiFine Fix it For the main While :( Here is The link for Github
 0
PM Link